LNMP0.8 eAccelerator和ionCube安装不上的解决办法

/root/lnmp restart时,报错如下:

Shutting down php_fpm  done
Starting php_fpm Failed loading /usr/local/php/lib/php/extensions/no-debug-non-zts-20090626/eaccelerator.so:  /usr/local/php/lib/php/extensions/no-debug-non-zts-20090626/eaccelerator.so: cannot open shared object file: No such file or directory
Failed loading /usr/local/ioncube/ioncube_loader_lin_5.3.so:  /usr/local/ioncube/ioncube_loader_lin_5.3.so: undefined symbol: zend_resolve_path
done
修改:/usr/local/php/etc/php.ini
原来:zend_extension=”/usr/local/ioncube/ioncube_loader_lin_5.3.so”
改成:zend_extension=”/usr/local/ioncube/ioncube_loader_lin_5.2.so”
php 5.2.17 使用ioncube_loader_lin_5.2.so不是5.3
原来:zend_extension=”/usr/local/php/lib/php/extensions/no-debug-non-zts-20090626/eaccelerator.so”
改成:zend_extension=”/usr/local/php/lib/php/extensions/no-debug-non-zts-20060613/eaccelerator.so”
eaccelerator路径是no-debug-non-zts-20060613 而不是no-debug-non-zts-20090626
转自http://www.cnblogs.com/iixiaowei/articles/2384524.html

华丽动感似扑克牌效果的圆角jquery焦点幻灯代码

来自腾讯游戏网的一款圆角jquery焦点幻灯代码,幻灯图片切换时似打扑克牌时抽叠效果,很华丽动感,幻灯效果很特别,有兴趣的不妨研究一下。

华丽动感似扑克牌效果的圆角jquery焦点幻灯

演示下载
转自:http://www.5icool.org/a/201107/486.html

RapidSVN:轻量级、可视化SVN客户端

前几天想查看下托管在Google Code上某工程的源码,发现没有安装SVN客户端,又不想使用复杂的TortoiseSVN,简单搜索了下,找到了RapidSVN这款轻量级的开源SVN客户端。
RapidSVN是一个使用C++与wxWidgets开发的跨平台、可视化SVN客户端。RapidSVN的开发初衷,是想综合现有的版本控制架构特性,做一个最佳的图形化Subversion客户端,对新接触版本控制系统的用户保持简易性、能够快速上手,同时对经验用户又要保留足够强大的功能。
由于完全使用C++开发,所以RapidSVN的运行速度很快,并且简单易用,适合像我这样不是很经常使用SVN的用户。
使用说明:已经做成便携版,直接运行RapidSVNPortable.exe,默认显示简体中文界面,当前版本RapidSVN 0.12.0 Revision 8051

RapidSVN-Portable

 
RapidSVN is a cross-platform GUI front-end for the Subversion revision system written in C++ using the wxWidgets framework.

RapidSVN下载信息

官方网站:www.rapidsvn.org

sudo apt-get 和dpkg命令大全

一、APT的使用(Ubuntu Linux软件包管理工具一)
apt-cache search # ——(package 搜索包)
apt-cache show #——(package 获取包的相关信息,如说明、大小、版本等)
sudo apt-get install # ——(package 安装包)
sudo apt-get install # —–(package – – reinstall 重新安装包)
sudo apt-get -f install # —–(强制安装?#”-f = –fix-missing”当是修复安
装吧…)
sudo apt-get remove #—–(package 删除包)
sudo apt-get remove – – purge # ——(package 删除包,包括删除配置文件
等)
sudo apt-get autoremove –purge # —-(package 删除包及其依赖的软件包+配置文件等(只对6.10有效,强烈推荐))
sudo apt-get update #——更新源
sudo apt-get upgrade #——更新已安装的包
sudo apt-get dist-upgrade # ———升级系统
sudo apt-get dselect-upgrade #——使用 dselect 升级
apt-cache depends #——-(package 了解使用依赖)
apt-cache rdepends # ——(package 了解某个具体的依赖?#当是查看该包被哪些包依赖吧…)
sudo apt-get build-dep # ——(package 安装相关的编译环境)
apt-get source #——(package 下载该包的源代码)
sudo apt-get clean && sudo apt-get autoclean # ——–清理下载文件的存
档 && 只清理过时的包
sudo apt-get check #——-检查是否有损坏的依赖
apt-get install 的用法
apt-get install 下载 以及所有倚赖的包裹,同时进行包裹的安装或升级.如果某个包裹被设置了 hold (停止标志,就会被搁在一边(即不会被升级).更多 hold 细节请看下面.
apt-get remove [–purge] 移除 以及任何倚赖这个包裹的其它包裹.–purge 指明这个包裹应该被完全清除 (purged) ,更多信息请看 dpkg -P .
apt-get update
升级来自 Debian 镜像的包裹列表,如果你想安装当天的任何软件,至少每天运行一次,而且每次修改了
/etc/apt/sources.list 后,必须执行.
apt-get upgrade [-u]

无法获得锁 /var/lib/dpkg/lock – open (11: 资源临时不可用)

问题:
运行程序更新时出现报错:
无法获得锁 /var/lib/dpkg/lock – open (11: 资源临时不可用)
解决:
其实这是因为有另外一个程序在运行,导致锁不可用。原因可能是上次运行更新或安装没有正常完成。解决办法是杀死此进程
sudo rm /var/cache/apt/archives/lock
sudo rm /var/lib/dpkg/lock

ubuntu中最简单的php环境配置php+mysql+apache+phpmyadmin

方法一:用tasksel install lamp-server命令一键安装。此方法非常简单,用提示,这里不做介绍。
方法二:
一、安装Apache2
apt-get install apache2
apache2启动、停止、重启命令
 
重启:service apache2 restart     或者       /etc/init.d/apache2 restart
停止:service apache2 stop     或者       /etc/init.d/apache2 stop
开启:service apache2 start     或者       /etc/init.d/apache2start
apache的默认安装时,会在/var下建立一个名为www的 目录,这个就是Web的根目录了,所有要能通过浏览器访问的Web文件都要放到这个目录里。
二、安装PHP5
apt-get install php5
在/var/www 目录下新建一个phpinfo.php文件
在里面写入
phpinfo();
?>
访问http://localhost/testphp.php
如果安装成功,会出现php的配置信息
三、安装MySql
apt-get install mysql-server
mysql默认配置只允许本机(127.0.0.1)连接,如果想让其它电脑能够访问你的数据库的话,编辑/etc/mysql /my.cnf
找到
bind-address = 127.0.0.1
用#注释掉
#bind-address = 127.0.0.1
此项操作需要重启mysql服务
用root帐户登录新建一个用户并赋予所有权限
grant all privileges on *.* to dxk@’%’  identified by “123456”;
在这条命令中新建了一个用户dxk密码123456并赋予了所有权限。
mysql服务的启动、停止、重启方法类似apache,这里不再多说。
四 、安装mysqlAdministrator
apt-get install mysql-admin
五 安装phpmyadmin
apt-get install phpmyadmin
在apache配置中的http.conf中添加/etc/phpmyadmin/apache.conf
http://localhost/phpmyadmin
如 果出现the requested URL /phpMyAdmin/was not found on this server错误.则要建立软连接,linux下不同于windows把整个phpmyadmin复制到站点下,使用命令安装完成后,它的目录在/etc /phpmyadmin和/usr/share/phpmyadmin/两个目录下,我们不需要将所有文件复制到你的站点下,只需要通过命令行方式建立软 连接,就可以以同样的方式访问。sudo ln -s /usr/share/phpmyadmin /var/www/

£24.49/年/256M/10G空间/500G流量的VPS —— Host Media UK

Host Media UK提供主机服务已经有8年以上的历史了,是AeonCube Networks的一个部门。主要提供虚拟主机、VPS、独立主机等,不同类型的主机价格都比较亲民。
Host Media UK的VPS机房位于德国。下面是最便宜的一款配置:

内存:256M
硬盘:10G
流量:500G
IP:1
价格:£24.49/年或者£3.49/月

所有服务提供30天退款保证。
Host Media UK的VPS提供的Virtualmin、Kloxo / LxAdmin等面板竟然还要收费。建议使用的同志可以以自己安装,都是免费的。
Host Media UK VPS详情:http://www.hostmediauk.com/web-hosting/vps/

$19.95/年/5G空间/100G流量的VPS —— ZenSix Hosting

ZenSix Hosting建立于2008年,只提供VPS。它的VPS有三种类型,分别为Budget-VZ1、Budget-VZ2、Budget-VZ3,价格分别为$19.95/年、$8.95/月、$10.95/月。
下面是这三款VPS的配置:

PlansBudget-VZ1Budget-VZ2Budget-VZ3内存256 MB384 MB512 MB空间5 GB15 GB30 GB流量100 GB400 GB800 GBIP111CPU124
仅支持3日退款。
服务器状态:http://status.zensix.com/
Budget-VZ1相对于BuyVM的$15年付来说,硬盘小、流量少、价格高。所以呢,还是选择BuyVM好些。
ZenSix Hosting官网:https://zensix.com/

frantech.ca 旗下BuyVM的便宜VPS只要15美元一年

BuyVM是FranTech下面的一个子品牌提供基于OpenVZ的VPS方案,frantech.ca主要 提供基于VMWare的VPS方案,使用的Fremont He.net线路的机房。相对于同机房的Linode价格便宜很多,而且提供原生的IPv6(需联系客服获得)。
测试IP:72.52.127.60   IPv6:2607:f358:1:fed5:3::244
速度的话很不错,和Linode的基本持平,VPS运行也比较稳定暂时没有出过问题,客服支持方面感觉挺慢,貌似国人办的,但是还是很受人追捧。
配置如下:256MB 内存( 512MB Burstable RAM)、1000GB 流量、30GB 硬盘空间 $3.50/月
地址:http://buyvm.net/
官方提供的测试IP:
IPv4: 72.52.102.3
IPv6: 2607:f358:1:fed5:1::1
下载测试: http://buyvm.net/100mb.test